Версии Joomla. Какую версию Joomla выбрать для сайта?

У многих новичков впервые столкнувшихся с созданием сайта, возникает вопрос:
Какую версию Joomla использовать для создания нового сайта?
В этой статье мы попробуем разобраться в этом вопросе...

UPDATE 1.01.2015 - Статья обновлена в соответствии с текущим положение дел в релизах Joomla.

На сегодняшний день существует 3 главных ветки CMS Joomla: ветка Joomla 1.5, Joomla 2.5 и Joomla 3

Согласно официальной странице версий Joomla на начало 2015 года версии Joomla 1.5 и Joomla 2.5 считаются устаревшими.

Версия Joomla 1.5, завоевавшая популярность c 2008 года, на текущий момент считается устаревшей и ее поддержка с сентября 2012 года окончательно остановлена. Расширения для нее также исключены из официального каталога расширений и в настоящее время найти их(в особенности последние стабильные версии) крайне затруднительно.

Что это значит и как следует поступать с сайтами на Joomla 1.5?

Рекомендация разработчиков Joomla - переводить сайта на линейку версий Joomla 3.

Моя рекомендация - грамотно все взвесить и определиться, нужно вам это или нет.

Основной довод в пользу миграции на Joomla 3 - стабильность и безопасность, возможность использовать новые возможности самого движка и новых расширений.

Основной минус - это затратно, как по времени, так и по финансам. Не каждый владелец сайта на Joomla 1.5 является программистом, а процесс миграции, как показала практика, в некоторых случаях может проходить не всегда корректно и без ошибок. В среднем цена работ специалиста по переносу сайта с Joomla 1.5 на Joomla 3 может обходиться от 5000 до 30000 в зависимости от его объема и количества сторонних расширений.

Поэтому - подходите к этому вопросу серъезно, предварительно собрав всю необходимую информацию и составив хотя бы общий план перехода.

Предупреждение! Для тех кто остался на версии Joomla 1.5!

В целях безопасности - обязательно обновитесь до последней версии - Joomla 1.5.26. Всю информацию и ссылки на пакеты обновлений вы найдете на официальной странице истории версии Joomla 1.5. А также установите последний патч безопасности - скачать можно здесь

Для сайтов на Joomla 2.5

Поддержка Joomla 2.5, как ни прискорбно, закончилась с приходом нового 2015 года. И хотя расширения для этой версии еще доступны в JED, разработчики вряд ли станут продлять ее поддержку.
Благо мигрировать здесь не надо и процесс обновления сделан более простым, фактически методом одной кнопки (ага, вот только бы работала она без сбоев ;-)

С сайтов на Joomla 2.5 рекомендовано автоматическое обновление до версий Joomla 3.

Joomla 3 - основная стабильная и поддерживаемая разработчиками версия!

Joomla3

Да, именно так и никак иначе! С 1 января 2015 года Joomla версий 3 - единственная официально поддерживаемая. На момент написания статьи актуальна версия 3.3.6 и готовится к выходу 3.4 (скорее всего весной 2015)

Какие преимущества дает использование данной версии?
  • адаптивность везде - как в админке, так и на фронте
  • улучшение юзабилити
  • встроенные Microdata (SEO)
  • множественные улучшения кода ядра
  • улучшение системы шаблонов за счет JLayout
  • новый роутер (в разработке)
  • избавление от Mootools
  • и многое прочее

Так что выбор вроде как бы и есть, но на самом деле его нет =)

Всем успехов в развитии своих сайтов и удачной миграции.

  • спасибо надо подробности для переноса старого сайта с 1.5 на 2.5
  • хорошо, попробую написать небольшой мануал, сам на днях буду переносить сайт с Joomla 1.5 на Joomla 2.5
  • Попробуйте обязательно. Если не получится, сообщите
  • Только что обновился с 2.5.11 до 2.5.14. В принципе проблем с ней нет: один раз была проблема с исчезновением доступа к админке, но исправил достаточно оперативно. Рабочий сайт именно на ней, задумывался перевести его на 3-ю версию, но сейчас думаю повременить - работает, что еще надо! Тестовый сайт на 3-й версии перестал работать где-то через неделю - по-моему что-то с базой данных, пока не разбирался. Как-то вот так!
  • с 1.7 до 2.5 перевел в свое время без проблем. Мануалов в сети предостаточно.
  • а почему не до 2.5.17 ?
  • Ну в смысле до 2.5.17